Admin Settings pages not loading

Incident Report for FloQast

Postmortem

Summary: Clients experienced failures when attempting to load most Admin pages within the application. The Team page remained accessible, but all other Admin pages were unavailable during the incident window, which lasted approximately 27 minutes.
Root Cause: During a scheduled release, certain application components were deployed out of the intended order. Specifically, updated client code was deployed before the underlying services it depended on were in place, causing Admin pages to fail to load when users attempted to access them.
Immediate Resolution: Engineering teams identified the deployment sequencing gap and completed the deployment of the missing components. Once the remaining services were deployed in the correct order, Admin page functionality was fully restored across all affected users.
Follow-up Actions: To prevent similar occurrences, the team is implementing clearer documentation of deployment ordering requirements for complex releases, ensuring all dependencies are explicitly captured and confirmed with relevant stakeholders before deployments begin. Internal release coordination processes are also being reviewed to reduce the risk of sequencing gaps, particularly in releases involving multiple simultaneous updates.

Posted Apr 01, 2026 - 14:17 PDT

Resolved

The fix has been deployed to all regions, and functionality is now restored. We will continue monitoring for any unexpected behavior.
Posted Mar 31, 2026 - 17:02 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 31, 2026 - 16:51 PDT

Investigating

We are currently aware of an issue resulting in specific admin settings pages not loading.
Posted Mar 31, 2026 - 16:40 PDT
This incident affected: US (Platform - US).