Review Note notifications are not being received for US clients.

Incident Report for FloQast

Resolved

The fix for this issue has been released. Users may experience a brief delay as the backlog of queued notifications is processed. We are continuing to monitor the situation and will share a Root Cause Analysis here when available.
Posted May 07, 2026 - 17:58 PDT

Investigating

We are currently investigating reports of notifications tied to Review Notes not being received
Posted May 07, 2026 - 16:20 PDT
This incident affected: US (Optimize the Close - US).