"Something Went Wrong" errors attempting to access FloQast

Incident Report for FloQast

Postmortem

Summary: On May 11, 2026, between 3:08 PM and 3:48 PM PT, all customers using the US production environment were unable to log in or access the application. Customers on the EU and APAC databases were not affected.

Root Cause: A recent deployment introduced a change to how the application constructs the web addresses used to communicate with its backend services. Due to a difference in how those addresses are formatted in the US environment compared to other regions, requests were being sent to an incorrect path, which prevented authentication and page access from completing successfully.

Immediate Resolution: The address construction logic was corrected, and the fix was deployed, restoring full access for all affected customers shortly thereafter.

Follow-up Actions: We are broadening automated test coverage to exercise environment-specific configuration more thoroughly, so this class of issue can be caught before reaching production. Additional monitoring and alerting are being added to detect access failures earlier. We are also working toward greater consistency in how service addresses are defined across our production environments to reduce the risk of environment-specific regressions going forward.

Posted May 14, 2026 - 14:48 PDT

Resolved

This incident has been fully resolved. US customers can access FloQast as normal.

A Root Cause Analysis will be published on this page shortly. We apologize for the disruption and thank you for your patience.
Posted May 11, 2026 - 16:27 PDT

Update

We are continuing to monitor for any further issues.
Posted May 11, 2026 - 16:09 PDT

Monitoring

A fix has been deployed for the issue affecting US customers. We are actively monitoring to confirm full stability.
Posted May 11, 2026 - 15:52 PDT

Update

We are continuing to investigate this issue. We have identified that this issue is isolated to our US region. Customers in the AU and EU regions have been confirmed as fully operational.
Posted May 11, 2026 - 15:31 PDT

Investigating

We are aware of an issue causing an "Something Went Wrong" error for users attempting to access FloQast. Users may be unable to load the application or see an unexpected error on login.

Our engineering team has been alerted and is actively investigating.
Posted May 11, 2026 - 15:27 PDT
This incident affected: EMEA (Platform - EMEA), APAC (Platform - APAC), and US (Platform - US).