AutoRec Matching: Transaction Import and NetSuite Sync Disruption

Incident Report for FloQast

Postmortem

Summary: Beginning at approximately 12:50 PM PT on May 7th, customers using the AutoRec Matching module were unable to upload transaction files or sync data from NetSuite. Uploads failed without clear error messages, and NetSuite sync jobs appeared to stall without completing. Upload functionality was restored at 8:38 AM PT on May 8th, and NetSuite sync functionality was restored at approximately 1:40 PM PT.

Root Cause: While resolving a separate platform issue, a routine redeployment of several background services caused two of them to load incompatible versions of a shared software component.

Immediate Resolution: Both services were restored to their correct configurations, resolving file upload and NetSuite sync failures across all production regions. A backlog of jobs that had stalled during the incident was also cleared manually, allowing them to complete successfully.

Follow-up Actions: The team is putting in place more rigorous validation steps around service redeployments to catch configuration mismatches earlier. Additional monitoring is being added to surface these issues faster if they occur.

Posted May 15, 2026 - 15:25 PDT

Resolved

The issue affecting transaction syncing has been resolved. Transactions should now be pulling in as expected for all connected clients. If you continue to experience any issues, please contact our support team.
Posted May 08, 2026 - 13:48 PDT

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 08:25 PDT

Investigating

We are currently investigating an issue affecting AutoRec Matching. Users are able to upload transaction files successfully, however uploaded transactions are not appearing for matching. Additionally, clients with NetSuite connected accounts are experiencing failures when pulling transactions or 'user is currently matching' messages.

We are actively investigating and will provide updates as they become available.
Posted May 08, 2026 - 08:25 PDT
This incident affected: EMEA (Automate the Close - EMEA), APAC (Automate the Close - APAC), and US (Automate the Close - US).