Errors Navigating the Single Workflow Dashboard

Incident Report for FloQast

Postmortem

Summary: On May 5, 2026, customers navigating between tabs on the Single Workflow Dashboard encountered an error modal displaying "Something Went Wrong." While the underlying dashboard data continued to load normally in the background, the error modal obscured the experience for customers using that view.

Root Cause: A recent update to the dashboard introduced a timing conflict in how the system managed temporary data storage during tab navigation. When customers switched between tabs, the system was clearing an internal data cache before a background process had finished using it, which triggered an error. The issue was most pronounced for customers on slower network connections, where the timing gap was more likely to occur.

Immediate Resolution: The update that introduced the timing conflict was reverted, restoring the proper sequence of operations.

Follow-up Actions: Test coverage is being expanded to test rapid navigation scenarios on the Single Workflow Dashboard to catch this class of issue before it reaches production. The underlying dashboard improvement that was reverted will be re-implemented with a safer approach before being reintroduced.

Posted May 08, 2026 - 12:14 PDT

Resolved

The fix for this issue has been released, and users should no longer be receiving errors when navigating the Single Workflow Dashboard. We are continuing to monitor performance, and a Root Cause Analysis will be shared here when it is available.
Posted May 05, 2026 - 13:04 PDT

Identified

We have identified the cause of the issue and are working on a fix. Users may still see the error when navigating between the Overview, Timeline, and Entities sections of the Single Workflow Dashboard. Closing the error will allow the page to load.
Posted May 05, 2026 - 09:33 PDT

Investigating

We are currently investigating reports of errors navigating the Single Workflow Dashboard. Users may see an error message when navigating between the Overview, Timeline, and Entities sections. After closing out of the error, the page should load as expected. The All Workflows Dashboard is not affected. We will post an update here as soon as we have more information.
Posted May 05, 2026 - 08:53 PDT
This incident affected: EMEA (Optimize the Close - EMEA), APAC (Optimize the Close - APAC), and US (Optimize the Close - US).