Issues with page load

Incident Report for FloQast

Resolved

A series of fixes has been deployed and all pages should load fully once again for affected customers.
Posted Feb 18, 2025 - 17:53 PST

Identified

Some users are currently observing a blank page upon loading various pages within the FloQast application. Engineering is actively working to resolve this issue.
Posted Feb 18, 2025 - 17:14 PST
This incident affected: FloQast Application Accessibility (Page Load).