Folders Tab Failing to Load

Incident Report for FloQast

Postmortem

Created: 2025-07-11 3:30 PM PST
Resolved: 2025-07-11 3:51 PM PST

Impact: FloQast users were unable to access the Folders tab of the application due to receiving an error message upon page load after selecting the Folders tab

Root Cause (Preliminary): The root cause was identified to be an implementation of a new infrastructure upgrade that was not successfully completed, causing a missing property to be passed with a Folders payload.

Mitigation: The issue was mitigated by reversing the attempted infrastructure upgrade and restoring the previous version.

Posted Jul 11, 2025 - 16:46 PDT

Resolved

This incident has been resolved. An RCA (Root Cause Analysis) will be made available as well.
Posted Jul 11, 2025 - 16:40 PDT

Update

We are continuing to monitor for any further issues.
Posted Jul 11, 2025 - 15:49 PDT

Monitoring

The issue has been identified, and the fix has been implemented. We are actively monitoring for any unexpected behavior, but we expect the application to be functioning properly again.

Thank you again for your patience while we investigated and resolved this issue.
Posted Jul 11, 2025 - 15:49 PDT

Investigating

We are currently investigating an issue causing the Folders page to fail to load. This is being given highest priority and updates will be shared as soon as we have them.

Thank you for your patience while we're working on getting this resolved.
Posted Jul 11, 2025 - 15:11 PDT
This incident affected: Optimize the Close (Folders & Replication).