Errors Loading Reconciliations and Folders pages

Incident Report for FloQast

Resolved

We have released the fix for this issue, and the Folders and Reconciliations pages are now loading successfully. We are continuing to monitor to ensure successful performance, and a root cause analysis will be posted here once it is available.
Posted Sep 15, 2025 - 09:20 PDT

Identified

The cause of the errors has been identified, and we are working on a fix. We can also confirm that this outage is only impacting customers on our US Database; the EU and APAC databases are not affected.
Posted Sep 15, 2025 - 09:14 PDT

Investigating

Customers are currently receiving "We're sorry—something went wrong" error messages when loading the Reconciliations and Folders pages, making those pages unavailable.
Posted Sep 15, 2025 - 08:46 PDT
This incident affected: General/Platform-wide (Page Load).