Reports of "Something Went Wrong" errors being received in various parts of the application.

Incident Report for FloQast

Postmortem

Summary: Clients experienced “Something Went Wrong” errors throughout certain parts of the application.

Root Cause: As part of ongoing security infrastructure improvements, FloQast migrated services to a more robust web application firewall (WAF) configuration. In pre-production environments, a supplemental ruleset had been in place that, by design, took precedence over certain standard security rules — effectively masking how those rules would behave in production. When the migration to the stricter production security configuration occurred, legitimate integration traffic was inadvertently caught and blocked.

Immediate Resolution: Engineering teams performed a full rollback of the affected deployments, restoring integration functionality for impacted customers. Once stable, the team began a careful analysis of the specific security rules to confirm that the appropriate level of restrictions was being adhered to.

Follow-up Actions: The team is taking a deliberate approach to reintroducing the production security ruleset in monitoring mode before enforcing blocks, allowing for validation against known traffic patterns.

Posted Apr 08, 2026 - 06:42 PDT

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 09:35 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2026 - 08:20 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 07, 2026 - 00:15 PDT
This incident affected: US (Optimize the Close - US, Automate the Close - US).