Contacts at Google have indicated that Google released a new fix to prevent further errors with uploading files via the Google Drive API. Our overnight monitoring has shown no further errors. We will continue to closely monitor logs across all customer regions since these errors were previously intermittent, but we are optimistic that customers should no longer experience errors uploading files after Google's latest update.
Posted Oct 04, 2024 - 07:50 PDT
Update
Google has acknowledged multiple reoccurrences of the API outage that blocks file uploads, and has reiterated that this is being treated with highest priority internally at Google. However, a timeline for a full restoration has not been offered yet, and customers across multiple regions continue to see intermittent errors when uploading files via the Google API.
Posted Oct 03, 2024 - 08:48 PDT
Identified
Google has acknowledged a recurrence of the 429 errors that are preventing some Google Drive (MyDrive and Shared Drive) customers from uploading files via the API. FloQast engineering remains in close contact with Google Cloud Support, and further updates will be posted as we learn them from Google.
Posted Oct 02, 2024 - 06:28 PDT
This incident affected: Integrations (Google Drive API).