Navigation UI Missing

Incident Report for FloQast

Postmortem

Created: 2025-07-07T15:11:03Z
Resolved: 2025-07-07T16:51:53.125Z

Impact: The navigation bar was not loading for customers in the US region, resulting in multiple parts of the FloQast application being inaccessible and unusable.

Root Cause (Preliminary): The root cause was identified as a WAF (Web Application Firewall) DDOS protection mechanism blocking traffic due to exceeding a rate limit threshold within a designated time period. The IPs being blocked were from an internal API Gateway.

Mitigation: The issue was mitigated by confirming the source of the IPs and the legitimacy of the traffic, then implementing an appropriate bypass.

Posted Jul 07, 2025 - 14:49 PDT

Resolved

We have confirmed success from the implemented fix and are now confident in saying the issue is resolved. Thank you for your patience while we worked to remediate this issue.
Posted Jul 07, 2025 - 10:09 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 07, 2025 - 09:12 PDT

Update

We have implemented what we believe to be the resolution to this issue. We are actively monitoring app performance for any indications of remaining issues.

Thank you very much for your patience as we looked into and released a fix for this issue.
Posted Jul 07, 2025 - 09:12 PDT

Update

FloQast is continuing to investigate this issue. Due to the navigation being missing, large portions of the application are currently inaccessible and cannot be used. This is the company's top priority to resolve.
Posted Jul 07, 2025 - 08:54 PDT

Investigating

The navigation bar is missing within the FloQast application. FloQast is currently aware of this issue and has all available resources working on discovery and resolution.
Posted Jul 07, 2025 - 08:20 PDT
This incident affected: General/Platform-wide (Page Load).