Something Went Wrong Errors

Incident Report for FloQast

Postmortem

Summary: On May 19, 2026, some customers on our US database experienced "Something Went Wrong" errors when attempting to access the FloQast platform. Affected customers were able to restore access by clearing their browser cache. The issue was fully resolved on May 20.

Root Cause: A recent update to how the platform routes login and authentication requests introduced a misconfiguration in the network path. Under the new routing, certain browser security checks received an unexpected redirect response, which browsers are required to reject per web standards. Once a browser encountered this error, it cached the failure, meaning subsequent requests by the same user continued to fail until the browser cache was cleared.

Immediate Resolution: The network routing configuration was corrected so that authentication requests reach the intended destination without triggering the redirect. The fix prevents recurrence of the caching problem going forward.

Follow-up Actions: Additional controls are being put in place to allow the team to respond more quickly to issues with future rollouts, limiting customer impact while investigations are underway. The production deployment pipeline is also being strengthened with additional safeguards to ensure rollback procedures work as expected when needed.

Posted May 29, 2026 - 11:04 PDT

Resolved

A fix has been released for this issue, and customers should no longer receive these "Something Went Wrong" errors. If you continue to receive the error, refreshing your browser will resolve it. We will continue to monitor, and a Root Cause Analysis will be posted here once available.
Posted May 20, 2026 - 12:42 PDT

Identified

We have identified the cause of the issue and are working on a fix.
Posted May 19, 2026 - 13:31 PDT

Investigating

We are currently investigating reports of "Something Went Wrong" errors when loading pages in the application. For any affected customers, clearing your web browser's cache should allow you to access the application while our engineers address the underlying issue.
Posted May 19, 2026 - 13:18 PDT
This incident affected: US (Platform - US).