Experiencing TB Folder 500 errors

Incident Report for FloQast

Resolved

Resolution:
Reverting the recent deployment fixed the issue.
Posted Feb 23, 2026 - 16:00 PST

Investigating

Summary:
Recent deployment of a core service caused a cascading 500 error when users attempted to access TB (Trial Balance) upload folders. The error originated from a failed HTTP request with status code 500.
Posted Feb 23, 2026 - 13:00 PST
This incident affected: EMEA (Optimize the Close - EMEA, Automate the Close - EMEA), APAC (Optimize the Close - APAC, Automate the Close - APAC), and US (Optimize the Close - US, Automate the Close - US).