The incident was caused by a software update that introduced a version mismatch, leading to an incompatibility with our production environment. This issue prevented a core part of our application from running correctly, resulting in the "Bad Gateway" errors and making the affected pages unavailable. Our engineering team was able to quickly identify and resolve the problem by reverting the incompatible software changes. To prevent a similar occurrence in the future, we have implemented additional automated alerts and expanded our testing procedures to catch such errors before they can impact our services.
Posted Aug 27, 2025 - 16:16 PDT
Resolved
We are continuing to see successful page loads throughout the application, and are now considering this incident resolved. A Root Cause Analysis will be shared here when available.
Posted Aug 26, 2025 - 12:44 PDT
Monitoring
The fix has been released, and pages are now loading successfully again. We are continuing to monitor to ensure successful performance and will post a Root Cause Analysis here when it is available.
Posted Aug 26, 2025 - 11:40 PDT
Identified
The issue has been identified, and a fix is currently being implemented.
Posted Aug 26, 2025 - 11:24 PDT
Investigating
Users are experiencing a Bad Gateway Error when loading pages in the application, making these pages unavailable. Engineering is investigating this with our highest priority.
Posted Aug 26, 2025 - 11:04 PDT
This incident affected: General/Platform-wide (Page Load).