Issue Fetching GL Balances from Quickbooks Online

Incident Report for FloQast

Postmortem

Summary:
Customers who have integrated their QuickBooks Online instance with FloQast began to see their Per GL balances in the Close module fail to correctly reflect balances from QuickBooks Online, and instead showed a zero balance.

Root Cause:
A monthly limitation of available API request credits was exceeded, and this resulted in all requests made to QuickBooks Online being rejected. The rejected requests caused a failure to obtain correct balance data, ultimately ending in the zero balance being displayed for reconciliations.

Immediate Resolution:
Proper functionality was restored by working to increase the available API request credits allocated from QuickBooks Online, allowing for the requests to return accurate data once again.

Follow-up Actions:
Additional monitoring will be put in place to more specifically measure third-party request quota limitations and usage, alerting FloQast in advanced of any potential conflicts.

Posted Oct 29, 2025 - 17:03 PDT

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 12:45 PDT

Monitoring

The source of the GL balances from Quickbooks Online failing to pull in has been identified and resolved. We are actively monitoring to ensure that the issue is fully mitigated.
Posted Oct 28, 2025 - 08:57 PDT

Investigating

We are investigating issues capturing balances in the per-GL column for entities connected to QBO.
Posted Oct 28, 2025 - 06:23 PDT
This incident affected: Integrations (QBO API).